HTTP2 zum laufen bringen

amiga1200

New Member
Ich habe eine Standard Suse Leap Installation.
Webserver mit SSL läuft super.
Nun wollte ich mich mal mit http2 anfreunden, aber irgendwie harkt es noch.
Ich habe eine Kurzanleitung gefunden

  • 1 Das korrekte MPM auswählen: APACHE_MPM=event.
  • 2 Das HTTP2-Module durch hinzufügen von http2 zum Wert von APACHE_MODULES aktivieren.
  • 3 Den Wert HTTP2 zu APACHE_SERVER_FLAGS um die von openSUSE mitgelieferte Konfiguration für HTTP/2 zu aktivieren.

Aber so einfach ist es nicht wie da beschrieben.

apache2-event ist installiert, aber wenn ich in die /etc/sysconfig/apache2 datei
APACHE_MPM=event

schreibe startet mein Apache nicht mehr.
standard steht dort APACHE_MPM=""


Die 2 Zeile mit APACHE_MODULES habe ich gemacht.
Aber was ist mit der 3. Zeile gemeint?
Original steht dort:
APACHE_SERVER_FLAGS="SSL"

soll hinter ssl noch http2?

In die Vhost Datei für SSL steht
SSLProtocol all -SSLv2 -SSLv3
Protocols h2 http/1.1

Vielleicht hat jemand schon mal unter Leap HTTP2 zum laufen bekommen und kann sagen was man machen musst.
 

amiga1200

New Member
Vielen Dank für dein Post,
ich habe heute morgen ein alten Server genommen, dort Leap 51.1 drauf gezogen,
Text Only, Lamp für Apache und MariaDB
Alle Update installiert und dann angefanngen

sudo a2enmod http2
sudo a2enflag HTTP2
sudo zypper remove apache2-prefork
hier wurde Apache komplett entfernt

sudo zypper install apache2-event

Aber hier wieder installiert mit apache2-event
shutdown -r now # rechner neustart


Nach a2enmod php7 lieft Apache mit php7 auch wieder.
Aber so richtig testen kann man es nicht, weil der Server nur im Extranet 192.168... läuf und kein SSL hat.
In der phpinfo steht auch nur SERVER_PROTOCOL : HTTP/1.1


In meiner Anleitung musste man doch in der /etc/sysconfig/apache2
das korrekte MPM auswählen: APACHE_MPM=event
aber nach einem Neustart block Apache wieder

So wurde es jedenfalls unter HTTP/2 im Apache auf openSUSE beschrieben:

journalctl -xe sagt


-- Subject: Unit UNIT has begun start-up
-- Defined-By: systemd
-- Support: systemd-devel Info Page
--
-- Unit UNIT has begun starting up.
Jul 05 15:00:18 Sontag2 systemd[17849]: Received SIGRTMIN+24 from PID 17880 (kill).
Jul 05 15:00:18 Sontag2 systemd[17850]: pam_unix(systemd-user:session): session closed for user root
Jul 05 15:00:18 Sontag2 systemd[1]: Stopped User Manager for UID 0.
-- Subject: Unit user@0.service has finished shutting down
-- Defined-By: systemd
-- Support: systemd-devel Info Page
--
-- Unit user@0.service has finished shutting down.
Jul 05 15:00:18 Sontag2 systemd[1]: Removed slice User Slice of UID 0.
-- Subject: Unit user-0.slice has finished shutting down
-- Defined-By: systemd
-- Support: systemd-devel Info Page
--
-- Unit user-0.slice has finished shutting down.
Jul 05 15:00:22 Sontag2 systemd[1]: Starting The Apache Webserver...
-- Subject: Unit apache2.service has begun start-up
-- Defined-By: systemd
-- Support: systemd-devel Info Page
--
-- Unit apache2.service has begun starting up.
Jul 05 15:00:22 Sontag2 start_apache2[17891]: [Sun Jul 05 15:00:22.620350 2020] [php7:crit] [pid 17891:tid 139998873413888] Apache is running a threaded >
Jul 05 15:00:22 Sontag2 start_apache2[17891]: AH00013: Pre-configuration failed
Jul 05 15:00:22 Sontag2 systemd[1]: apache2.service: Main process exited, code=exited, status=1/FAILURE
Jul 05 15:00:22 Sontag2 systemd[1]: Failed to start The Apache Webserver.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: systemd-devel Info Page
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Jul 05 15:00:22 Sontag2 systemd[1]: apache2.service: Unit entered failed state.
Jul 05 15:00:22 Sontag2 systemd[1]: apache2.service: Failed with result 'exit-code'.
Jul 05 15:00:32 Sontag2 smartd[687]: Device: /dev/sda [SAT], SMART Usage Attribute: 195 Hardware_ECC_Recovered changed from 81 to 76
lines 3750-3788/3788 (END)
 
Zuletzt bearbeitet:

amiga1200

New Member
gelesen schon, aber konnte nichts damit anfangen.
einfach
sudo zypper remove apache2-mod_php7
und

sudo zypper install php7-fpm
?

oder wird es einfach in einer config Datei eingetragen
xx= apache2-mod_php7 zu
xx = php7-fpm.

ist zwar nur eine Testversion, aber wollte nichts verhauen.
 

amiga1200

New Member
VMs haben wir in die Firma, aber zum experimentiere nehme ich gerne ein alten Rechner.

und im 192.168 Netz passiert nichts.
Ich bin auch mehr der Android Entwickler.

:)Ich dachte du sagest mir ob
sudo zypper remove apache2-mod_php7
sudo zypper install php7-fpm
richtig ist

ich könnte es zwar testen, will meine Test Installation ungerne verhauen.


In der Standard Installation setzt Suse Apache als Modul auf,
jetzt mit mein HTTP2 Fix wird daraus eine CGI Version richtig?
Geht http2 nicht über die Modul weise?
 
Oben